Can I download old versions of the MultiSafepay plugins?

We advise you to always use our latest stable plugin version. However, if you would like to use an older version of our plugins, please contact our Integration Team at [email protected]